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Linux Practical 2 

Advanced Topics  

 
This session is designed to introduce you to more sophisticated usage of the underlying UNIX-based 
Linux file system and computing infrastructure used within the School of GeoSciences. 
 

1. Applications And Processes 

- How to control applications from the command line.  Background processes. 
 

2. Complex And Linked Commands 

- Linking together commands you already know, to do real, useful work. 
 

3. Managing Printing in Linux  

- How to check on print job progress and to cancel unwanted jobs. 
 

4. Linux Text Editors: GNU Emacs; Controlling the Default Editor  

- Introducing the GNU Emacs editor – for authoring content, for data processing, for programming. 
 
This practical will allow you to familiarise yourself with the basics of working with Linux in the School 
of GeoSciences.  The practical workbook is designed for you to work through during the practical 
session, when there are people around to help.  It is NOT a definitive reference!  Much more 
information is available on the web, including this document which can be found at: 
 

www.geos.ed.ac.uk/~gisteac/wkzero 
 

http://www.geos.ed.ac.uk/~gisteac/wkzero
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 Making sense of this Workbook 

  
 Throughout this practical workbook any commands you have to type, will be given in bold 

courier font, and prompts or responses from the computer will be in plain courier 

font, for example: 

 
 s1234567@baltic10:~$ pwd 

 s1234567@baltic10:~$ cd / 

 s1234567@baltic10:/$ ls –al 

  
  Will indicate tasks to be completed 

 
Specific questions you can answer will have a letter in the left hand margin - a), b), c) etc. 

  
 Other text to note, or buttons to click or be aware of, will be introduced in bold paragraph 

body text. 
  
 

 This symbol indicates text of high importance or direct usefulness during the practical. 
 

 This symbol indicates further useful information it would or might be useful to know later. 
  
 s1234567 represents your unique student login (matriculation number preceded by an s.) 

 
Note: For staff this may be first initial immediately proceeded by surname up to 8 characters 
(e.g. jjohnson, jjohnso1, etc.) and for visitors with an initial vnfsurna (e.g. v1jjohns). 

  
 ~ (known as tilde) represents your home directory.  In the command prompt above note that 

this will change to reflect whichever directory you are currently working in. 
  

 

 

 
Note that Linux is case sensitive - all commands must be typed exactly as they are shown 
on this sheet or they will not work! 
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There follows a set of attainment targets listed below.  Make sure you can do everything in the list.  
Many students will be using Linux throughout the year.  It is therefore important that you speak to 
one of the demonstrators if you are confused or have been unable to complete the tasks. 
 

  

 Targets for this Session 

  
 You should be able to: 

 

 Do everything you did in the previous practical 

 Start a process in the background 

 Move an active process to the background 

 List the processes you have running 

 Kill a process you no longer need 

 Use pipes to link commands together 

 Redirect output from a command to a file 

 Manage print jobs from the command line 

 Edit text files in the Linux environment 

 Know how to change your default editor for command line use by 3rd party apps 

 
And you should still know: 
 

 When to switch off the machine and go outside… 
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1 Applications And Processes 

  
 Earlier you started emacs from the command line.  What happened to the command line?  It 

locked – you could write a bestseller, but couldn't type any further commands until you 
closed emacs.  While with XRDP we can open more Terminals to get around this, too 

many windows quickly becomes hard to manage and is no solution for automated processes 
which may need to open a child (sub)process without preventing their own progress. 
 
The correct way to get round this is to use Linux's ability to run programs as separate 
processes and to run specific applications either in the foreground or the background.  
The simplest way to show this is with an example.  Today we will use the fun old graphical 
UNIX program xeyes here, however the principles are the same for any software.  So: 

  
 

 
 

 
 

 
 
 
 
 

 
 
 

a) 

Log on to the Linux server using xrdp as before – see https://blogs.ed.ac.uk/geosciences-
it-help/remote-desktop/ if you need to remember how.   
 
Now let’s run xeyes at the command line.  Open a Terminal window from the menu bar. 

 
s1234567@baltic10:~$ xeyes 

 
A new window should pop up and the command line should "freeze" – nothing you type will 
make any difference.  At some point some you will need to get control back.  So… 
 
Press CONTROL ([Ctrl]) and Z at the same time on the keyboard.  (Click on the 

Terminal window to re-activate it if necessary first before pressing Ctrl+Z.) 

 
What happens?  (If nothing happens you may need to click on the Terminal window first.)  
What messages do you get?  What does xeyes do when you click on it?  Do the eyes still 

follow your mouse pointer? 
 
…………………………………………………………………………………………………………… 

  
 
 

 

You have stopped the xeyes process – but that's not much use either, is it?  So, type: 

 
s1234567@baltic10:~$ bg 

 
This puts xeyes in the background – you can work with it but you can also work with the 

command line.  xeyes is now running as a background process.   

  
 
 

 
 

 
 
 

 

You can bring xeyes back to the foreground by typing: 

 
s1234567@baltic10:~$ fg 

 
Now close the program by pressing Ctrl-C (i.e. hold Ctrl + [press] C or you can click the 

Close gadget).  An easier way to achieve all of this would have been to type: 
 
s1234567@baltic10:~$ xeyes & 

 
in the first place – this means that xeyes starts as a background process, freeing the 

command line to do something else, or allowing you to safely log out and go home! 
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b) 
 
 
 
 
 
 
 
 
 
 

 

xeyes is (are!) quite happily sitting in the background – but what happens if something goes 

wrong?  What if xeyes (or a really important application) stops working?  How do you 

control it if none of the buttons respond?  This can be a problem with scientific or data 
analysis software if you are using large datasets.   
 
There are two commands that are very important for this: ps and kill. 

 
s1234567@baltic10:~$ ps 

  PID TTY          TIME CMD 

18888 pts/175  00:00:00 xeyes 

18890 pts/175  00:00:00 ps 

19274 pts/175  00:00:00 bash 

 
ps tells you the processes you have running on a machine.  The command above is very 

useful – it uses a flag so that you can find all the processes belonging to a user.  Try 
typing ps -u s1234567 where s1234567 is, here, the username of a classmate (you can 

use who or users to obtain a list of logged in users if required).   

 
How many processes are they running and what are they? 
 
…………………………………………………………………………………………………………… 
 
…………………………………………………………………………………………………………… 
 
The PID column tells you the process ID of a specific task.  In the example above, xeyes 

has a PID of 18888.  We can close down this process from the command line with the 

command kill.  Try shutting down xeyes.  Replace the PID of the example below with 

your own PID from the previous ps command. 

 
s1234567@baltic10:~$ kill -9 18888 

 
xeyes should now disappear.  What does the -9 do?  Stops it dead, no argument, no 

messing about.  But, if a process has children (e.g. secondary processes or other sub-
windows), this may not kill them – you will have to do this manually. 

  

 

 

 
Note: Before moving on you should check that you do not have any background xeyes 

processes still running!  If so, you can safely kill these in the same way. 

 
It is a good idea to check you have no processes running in the background before you 
log off!  One user in the School was found to be hogging 25% of the processor time of a 
UNIX server machine, even though they had not sat at it for two weeks, just because of 

unkilled background processes! 
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2 Complex and Linked Commands  

  
 

Pipes 

  
 
 
 

 
 
 
 

c) 
 
 
 
 
 
 
 
 

 
 

d) 

Pipes allow you to link commands together so that the output from one command is used as 
the input to another. 
 
s1234567@baltic10:~$ ps -ef | grep s1234567 

 
where s1234567 is the username of your neighbour. 
 
What does it do?  Clue: ps -ef lists all the processes running on the machine and gives a 

long description of them. 
 
………………………………………………………………………………………………………….. 
 
………………………………………………………………………………………………………….. 
 
Try this one: 
 
s1234567@baltic10:~$ who | grep 's1' 

 
What does it do (remember to look at man for help on what a command does.)  Ask if you're 

not sure. 
 
………………………………………………………………………………………………………….. 
 
………………………………………………………………………………………………………….. 

  
 

Long Command Lines and Multiple Commands on one line 

  
 
 
 
 
 
 
 

 
 
 
 

e) 

To split a command across more than one line you use the \ character (see the next page 

for an example involving the grep command).  This can be very useful if you have long 

arguments. 
 
You can also put more than one command on a line if you split them up with the ; character.  

For example: 
 
s1234567@baltic10:~$ cd /; pwd; cd ~; pwd 

 
(Note that / signifies the root or top(!)-level directory on UNIX/Linux systems – an inverted 
tree!) 
 
What do you think this does?  What output do you get? 
 
………………………………………………………………………………………………………….. 
 
………………………………………………………………………………………………………….. 
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Redirecting Output 

  
 
 
 
 
 

 
 

 
 

 
 
 
 
 
 
 
 
 

Nearly all the commands you have used so far have returned some information to the 
screen.  Most of the time, this is fine, but you may want to store this information for future 
reference.  You can do this by redirecting output from a command to a file, using the > 

character.  Try the following: 
 
s1234567@baltic10:~$ cd my_wkzero 

s1234567@baltic10:~/my_wkzero$ who > users.txt 

 
What has happened?  Nothing is returned to the screen.  The information has been stored in 
a file called users.txt.  Look at this file using more or less or another viewer, in 

Windows if you wish, and check it contains the correct information.  Note this file is simply 
stored in the same directory (i.e. the current directory).  If we wished to store the file 
elsewhere we could provide a fuller path in our redirection command, e.g. 
 
EXAMPLE 
s1234567@baltic10:~/my_wkzero$ who > ~/userlist.txt 

s1234567@baltic10:~/my_wkzero$ more userlist.txt 

userlist.txt: No such file or directory 

s1234567@baltic10:~/my_wkzero$ more ~/userlist.txt 

. 

. 

. 

Etc. 

  

 
Compound Commands using \ – An example with grep 

  
 All of the examples above have been very simple.  You are now going to use a combination 

of these to do some useful work.  In /geos/netdata/wkzero/ there is a file called 

nation_data.txt.  The first few lines are shown below. 

  
 s1234567@baltic10:~/my_wkzero$ head /geos/netdata/wkzero/nation_data.txt 

Nation  Continent       Area (km2) 

Greenland       Europe  4501027.684 

Canada  North America   472653.2342 

Canada  North America   98308.28442 

Norway  Europe  38767.3129 

Norway  Europe  87746.89587 

Canada  North America   27865.78227 

Canada  North America   11483.96442 

Canada  North America   8817.206272 

Russia  Asia    26852385.1 

 
This file was exported from Microsoft Excel.  It is a tab-delimited file (i.e. the columns of data 
are separated by tabs).  The first line shows the titles of the columns and the following lines 
record the nation, continent and area in square kilometres of all the polygons (islands and 
land masses) in a map of the world.  The file is 275 lines long (measured with wc). 
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 What you are going to do is find all the land masses (polygons) in North America with 
an area greater than or equal to 100000 square kilometres and store their nation 
name, continent, and area in a new file. 
 
You could do this by opening the file in a text editor and searching through it, but there is a 
much faster and more elegant way… Type the command below (hitting <return> at the 

end of each line) – remember you can use <tab> to auto-complete paths e.g. /geos… etc. 

  

 

 

 
DO NOT type the > brackets marked on the left.  These will appear in place of the usual 
bash$ command prompt when you continue a long command on a new line.   
 

 

  
 s1234567@baltic10:~/my_wkzero$ grep 'North America' /geos/netdata/wkzero/nation_data.txt | \ 

> grep '[1-9][0-9][0-9][0-9][0-9][0-9]\.' > \ 

> nation_summary.txt 

  
 Now have a look at the new file nation_summary.txt.  Does it answer the question 

above?  The command looks very complicated so the following explanation is line by line: 
  
 s1234567@baltic10:~/my_wkzero$ grep 'North America' /geos/netdata/wkzero/nation_data.txt | \ 

 
This line searches the file /geos/netdata/wkzero/nation_data.txt, looking for all 

the lines in it (i.e. representing each distinct polygon, island, or land mass) that have the text 
North America in them (listed under the heading continent that is – which almost explains 

why Russia is amongst them!).  The pipe | symbol towards the end of the line instructs 

Linux to take the output from this command and send it to another command, rather than the 
screen – in this case the next command is on the following line.  The \ symbol tells Linux the 

whole compound command continues on another line… 
  
 > grep '[1-9][0-9][0-9][0-9][0-9][0-9]\.' > \ 

 
Note the > symbol at the start of this line.  This is NOT a redirect symbol; it is merely a 

marker showing that the command is a long one split across two or more lines.  It is NOT 
part of the command and should NOT be typed! 
 
This line searches the output from the first grep command.  This time it looks for lines that 

include a decimal point preceded by six or more numbers.  This is an example of using a 
regular expression to search.  Each set of square brackets and numbers [0-9] means 

"any character between 0 and 9" i.e.  0 1 2 3 4 5 6 7 8 or 9.  Note: The first is, of 

course, [1-9] since we wish to find land masses greater than or equal to 100000 sq km.  

The full stop or period . has a special meaning when it is in a regular expression so to 

search for it you need to put a \ before it.  This means "do not interpret the next character as 

a special character, just as a normal character".  (This is in fact also what the end of line 
backslash does – it tells Linux to ignore the newline entered when your press <Return> or 

<Enter>.)  The sets of square brackets and full stop together mean six numbers followed 

by a decimal point, so this command line searches and finds all the lines of text that have a 
number in them greater than or equal to 100000.  The > symbol at the end of the line is this 

time an actual user-specified instruction which redirects the output into a file, shown on the 
final line: 
 
> nation_summary.txt 
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3 Managing Printing with Linux [REFERENCE ONLY] 

  
 Monitoring Printer Queues  

  
 
 
 
 
 
 
 

 
 
 
 
 
 

 
 

In the University cloud printing the following may be of limited direct use however the 
commands are worth knowing of should you work on another Linux/UNIX facility and have 
need to control printing or perhaps to use print commands programmatically. 
 
You can monitor the progress of jobs using the lpq command.  This shows the list of 

pending print jobs for your default printer.  For example: 
 
s1234567@baltic10:~/my_wkzero$ lpq 
EdPrintPull is ready and printing 

Rank    Owner   Job     File(s)                         Total Size 

active  snnnnnn 234253  nation_summary.txt              1024 bytes 

 
Or if you try it when there are no jobs pending: 
 
s1234567@baltic10:~/my_wkzero$ lpq 
EdPrintPull is ready 

no entries 

 
You can also monitor printers other than your default using the –P option to specify the 

relevant printer.  For example: 
 
s1234567@baltic10:~/my_wkzero$ lpq –Pprintername 

printername is ready 

  
 Removing Print Jobs from the Queue [IF PERMITTED!] 

  
 
 
 
 

() 
 
 
 
 
 
 

To remove a job from the queue (perhaps if you can’t afford to wait if the printer is busy and 
you wish to try submitting to another printer) you should note the job number.  You can then 
use the lprm command, specifying the job number, to delete the job from that queue. 

 
For EXAMPLE: 
 
s1234567@baltic10:~/my_wkzero$ lpq 

Cloud-Mono is ready and printing 

Rank    Owner   Job     File(s)                         Total Size 

active  snnnnnn 234253  nation_summary.txt              1024 bytes 

s1234567@baltic10:~/my_wkzero$ lprm 234253 

 
Note: With modern network and printer speeds you are unlikely to be fast enough to cancel 
a print job and you can simply choose not to print it (or delete) it at one of the network 
copier-printers located around the University estate.  The lprm command however is silent if 
successful, otherwise you’ll get a message along the lines of: 
 
lprm: Job #420021 is already completed - can't cancel. 
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 Advanced Linux Printing – Code/Data Tables  

  
 Printing text to laser printers – e.g. program code listings 
  

 

 

 
Note: Don’t worry about printing to cloud printers – as with printing from Windows you are 
only billed should you choose to physically print from one of the multi-function devices! 
 

 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

When printing computer code listings you must format all code in a non-proportional font 
such as Courier to retain the fixed-width layout used.  This is essential for accurate reading 
and analysis of the code.  A good text editor (e.g. emacs, or PSPad/NotePad++ on 

Windows) will allow this, however if you are laying out code as part of, say, a Word or 
OpenOffice document, you will have to manually format the listings with the correct font. 
 
It is also possible to print such listings from directly in Linux (or other UNIX variant).  This 
can be useful if there are problems printing from Windows or where you may wish to 
program a print as part of a series of automated tasks (this is the power of a command-line 
environment – remember you can always print to a virtual printer file!)  You can simply print 
to a postscript print file using lpr (or lp) and use the relevant Linux command to submit the 

file to the printer. 
 
You can also use the printing commands either interactively, typing a series of lines and then 
[Ctrl-D] to finish and submit to the printer, or by specifying a text file to print.  E.g. 

 
s1234567@baltic10:~ my_wkzero$ lp nation_summary.txt 

request id is EdPrintPull-27630 (1 file(s)) 

 

lp and lpr use different letters for specifying some printing options, but are virtually 

identical.  lp though does provide useful feedback when a job is submitted unless run with 

the silent flag –s whereas lpr runs ‘silently’ at all times. 

 
Sophisticated printing is easily achieved using the various options available to us when 
specifying one of the printing commands.  For instance to print two pages to an A4 side we 
can issue a command like: 
 
EXAMPLE 
 
s1234567@baltic10:~/my_wkzero$ lpr <file> -Pprinter –o sides=two-sided-long-edge 

  
 
 
 
 
 

 

The a2ps utility is also useful for compressing long code for document production since it 

prints a reasonably attractive listing in two columns with the filename as a heading. 
 
EXAMPLE 
 
s1234567@baltic10:~ my_wkzero$ a2ps nation_summary.txt 

[nation_summary.txt (plain): 1 page on 1 sheet] 

request id is EdPrintPull-234260 (1 file(s)) 

[Total: 1 page on 1 sheet] sent to the default printer  

s1234567@baltic10:~ wkzero$ 
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4 Linux Text Editors: GNU Emacs; Controlling the Default Editor 

  

 

 

 
GNU Emacs: Why?  (Will work in graphical mode or text-only mode!) 
 
Various editors are available for use on the School’s Linux machines.  These consist of at 
least vim, nano, and emacs (this is GNU Emacs and it will work with an X display or in a 

text-only terminal window – very useful!).  You can see many of these from the menus when 
logged into the xrdp environment. 
 
The default editor, sometimes invoked by other programs e.g. .SQL Plus (sqlplus) as 

required, is initially set on the new Ubuntu based machines to be vim.  (The odd name vim 

is short for vi improved with the original vi being a take on the command ue which was used 
for an earlier UNIX emacs variant called microemacs!!  The u is the closest thing to greek 
letter mu, used in scientific notation for micro, hence ue!) 
 
Most School servers however have the default editor changed to be the incredibly simple 
and easy to use nano (worth a look!).  You can easily make edits to text files and then press 

Ctrl+x to leave (you’ll be asked if you wish to save).  You may find this is sufficient for most 
simple tasks (however more sophisticated editors offer features like syntax highlighting 
useful for coding where different parts of your code are coloured based on their function.) 
 
Editing in vi(m) however is notoriously challenging but it is a quick and powerful editor 

accessible to all connection types (command line only or command line within a remote 
desktop environment).  If you ever find yourself in vim and need to get out you can simply 
make your edits then type :q (shift+colon key, then q) to leave, and if necessary you can 
force it to abandon any changes by typing :q! (i.e. adding the exclamation mark). 
 
We recommend however that you use Emacs on the School Linux systems as it is straight-
forward to use yet offers a sophisticated graphical system when using xrdp.  We will take a 
brief look at Emacs now.  (Nano may also be a suitable very user-friendly choice of basic 
general-purpose editor but nowhere near as powerful as Emacs.) 
 
Modern editors such as Atom and VSCode are also available and highly recommended but 
these may not run in text-only format (e.g. in low bandwidth situations) and for that reason 
we still recommend you Emacs be set as the default editor due to its balance of power, 
flexibility, universal accessibility and ease of use.  Emacs can be run with the –nw (no 
windows) flag for command line use but will usually select this mode if it cannot detect a 
running X server for graphical display. 
 
Emacs has an incredible heritage, offers incredible power yet is easy to get started with – 
particularly via xrdp.  However if you are still wondering why we can’t use a lean modern 
editor or simply a Linux version of some popular Windows/Mac text editors then you might 
find the following informative. 
https://www.quora.com/Why-do-I-need-to-use-Vim-or-Emacs-in-2018 
http://emacs-fu.blogspot.com/ 
 

  

https://www.quora.com/Why-do-I-need-to-use-Vim-or-Emacs-in-2018
http://emacs-fu.blogspot.com/
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 A First Look at GNU Emacs 

  
 Start Emacs (gui) from either of the Applications ► Accessories or Applications ► 

Programming menus.  (Alternatively you can start it from a terminal by typing emacs.) 
 

 
 
Creating a new text file (document) 
Click on the left-most icon (button) to create a new file.  You will be asked for a location and 
filename.  You can browse the filesystem to a suitable location (you will start off browsing in 
your home directory) and then specify a filename.  The file is only created there once you 
add some text content and go to File ► Save or click the Save icon.  Instead of using the 
icons (hover over each to find out what they do) you can use the menus entirely – e.g. File 
► Visit New File to do the same as we have just done above, or use keyboard short-cuts. 

  
 Opening and Saving Files 

A simpler alternative is to make a change to an existing file which you can do from the 
menus via File ► Open File.  To save any changes to this, or equally to save a newly 
created file that you have added content to, you can go to File ► Save. 
 
Note that you can Save As from an unused empty file which will simply effectively rename 
the file so long as no content has been added. 
 
The best option is just to play with the program to get used to the necessary basics which 
shouldn’t take too long!  There is however a built-in tutorial available from the Help menu.   

  
 Handy Keyboard Shortcuts (Refer back to these when required!) 

No mouse?  Command line access?  Remote working and no xrdp?  Emacs menus = F10!! 
 
As well as using the menus you can use a number of quick keyboard shortcuts which are 
worth remembering.  (Note: These are especially worth learning should you make Emacs 
your default editor and then need to connect with a text only Terminal!  However, if you 
remember nothing else F10 will get you to the menus where you can see the shortcut 
combinations.  None of this is an issue if you use xrdp with the Windows Remote Desktop 
Connection client and control the screen size/colour depth if bandwidth is an issue, but it is 
worth mentioning here so you can refer back.) 
 
Most shortcuts consist of pairs of key combinations usually involving one or more control-
key pairs perhaps followed by one further key press – e.g. to Save hold down control (ctrl) 
and press x (while still holding ctrl) then release both and immediately press and hold ctrl 
once more whilst pressing s.  The most useful combinations are outlined below. 
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 Note: In Emacs’ menus Ctrl (control) is shown by C.  You may also see M meaning the 
Escape (ESC) key, but also Alt in Emacs.  A full tutorial can be found within the program 
from Help ► Tutorial (or C-h t, i.e. Ctrl+h then press t). 
 
Save Ctrl+x then Ctrl+s (C-x C-s) 
Save As Ctrl+x Ctrl+w (C-x C-w) 
Quit Ctrl+x Ctrl+c (C-x C-c) 
Visit New File Ctrl+x Ctrl+f (C-x C-f) 
Open Directory Ctrl+x then d (C-x d) NB Only one use of Ctrl here! 

 
There is no Open File shortcut since if no Window system were available the program could 
be run specifying a file to edit (either new or existing).  The Visit New File function will either 
create and open a new file for editing or open an existing file in the same way as Open File. 
 
And from the Edit menu: 
 
Cut C-w C-w 
Copy M-w M-w (M is the Escape or ESC key; or also Alt in Emacs ) 
Paste C-y C-y 
Undo C-x u 
Select All C-x h 

 
Plus the following are invaluable – but not mentioned on the menus!! 
 
Kill (a single line) C-k 
Set Mark (block editing) C-SPC (SPC = Space) – use cursor keys then cut/block cut 
Block Cut C-x r k  (Copy using cut, paste, then move to paste again) 
Block Paste C-x r y (y means yank as in yank out in Emacs speak!!) 

 

  
 

 A Task for You 

  
 Time to get you active again and give the brain a workout! 

 
Try editing (correcting!) the file jefferson.txt that you downloaded in the previous 

session via FTP.  (Alternatively you can find the file if.txt on netdata should you need to.) 

 
If you struggle to find the file remember you can use the Caja file manager to explore the file 
system.  If you don’t have the jefferson.txt file don’t worry just copy the if.txt file 

from netdata instead.  (You can get the jefferson.txt file from the wkzero web pages). 

 
s1234567@baltic10:~/my_wkzero$ cd ftpdata 

s1234567@baltic10:~/my_wkzero/ftpdata$ emacs jefferson.txt 

 
Alternatively start Emacs from the menus and use File ► Open File. 
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 Setting the default editor in Linux for third party applications [OPTIONAL] 

  
 Should you wish, you can change your default editor to emacs (Emacs) however if you 

regularly use command line SQL *Plus (e.g. if you are taking the Spatial Modelling and 
Analysis course) it is highly recommended to use nano instead.  This should be set by IT 

already but if not (e.g. if vi or vim appear upon typing EDIT within SQL *Plus) then you can 

follow the steps below.  (To get out of vi first, remember use the sequence :q! i.e. colon q !) 

 
You can still use Emacs as required, either graphically with menus as you may be used to, 
by typing emacs followed by the file path/name required, or more quickly in text (no window) 

mode with: emacs –nw followed by the file path/name required.  The ensures Emacs 

doesn’t attempt to launch a graphical window via an X-server taking time and resource and 
perhaps causing the window to disappear behind an enlarged terminal window or similar. 
 
Quicker editing (e.g. in SQL *Plus for Oracle database users) can however be achieved 
using the quick and responsive text-only nano editor (you can always still use any of Emacs, 
Atom, VS Code or any Linux editor you like for editing of other files or fuller queries).  Also 
see the box below on editing on other operating systems such as on your own laptop etc. 
 
Setting the Linux editor: 
To set the editor for each login session you first need to edit a special hidden file (remember 
– that’s one that starts with a dot – see the earlier practical if unsure).   
 
You also need to make these files visible in Emacs by ticking the Show hidden files box to 
the bottom left of the Find File: dialog box. 
 

 
 
The file to be edited is called: .bashrc.  Alternatively, just type: emacs ~/.bashrc. 

 
Add the following line at the very end of the file (be careful not to change anything else!) 
 
export EDITOR=emacs 

 
EDITOR must be in capitals and is a Linux/UNIX environment variable. 

 
Once saved emacs will become the default editor in every new Terminal session launched. 

  

 

 

 

 
Editing Locally (e.g. on laptop/PC) – beware! 
*Note: If you must use a Windows based editor (particularly for developing computer code)  
then you may be best to use the SFTP functionality of MobaXTerm which will allow editing 
on Windows of remote Linux files but, critically, preserving/respecting the remote file 
permissions settings.  These can be important, especially for code running on web servers 
which may have additional security restrictions controlled by these file perrmissions.   Editing 
on local computers of files over Samba connections (mapping drives in Windows; smb: on 
Macs) is strongly discouraged due to the permissions being reset upon each edit/save. 
 

  
 That will suffice for this session – hopefully you will find this material of use in weeks to 

come! 
  

 


